NSX manager cannot be seen when logged into the vSphere web client with a user account
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Article ID: 309114
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Updated On:
Products
VMware NSX
Issue/Introduction
Symptoms:
NSX Manager is registered to vCenter and SSO, and both show green connected status in the NSX Manager web interface.
Logging into the vSphere Web client shows no NSX Manager available under Networking & security, or only some of the expected NSX Managers are available in an ELM multi-vCenter/multi-NSX Manager environment.
When logging into the vCenter Web Client using the same account that is used to register NSX Manager to the vCenter in the NSX Manager Web interface under "Manage vCenter Registration", the NSX Manager appears.
Environment
VMware NSX for vSphere 6.2.x VMware NSX for vSphere 6.3.x VMware NSX for vSphere 6.4.x
Cause
This issue occurs because NSX Manager requires access permissions to be assigned separately for each NSX Manager.
Resolution
By default, the account used to register NSX Manager to vCenter on the NSX Manager web interface > Manage > NSX Management service (or through the Manage vCenter Registration link) under vCenter Server > vCenter User Name is granted full access to NSX Manager.
To add and assign permissions to an account:
Log on to the vSphere web client with the account having full permissions.
Navigate to Networking & Security > NSX Managers > Select the NSX Manager > Manage > Users.
Click the green plus sign to add an account or group to NSX. Note: When adding individual accounts, the SSO lookup service is not required. The SSO lookup service is required when granting access to SSO groups, as the NSX Manager uses this service to determine the group membership to see if the account being used to access NSX is included in one of the specified groups.