ESXi boot process hangs at "iscsi_vmk loaded successfully"
search cancel

ESXi boot process hangs at "iscsi_vmk loaded successfully"

book

Article ID: 308988

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

This article provides troubleshooting guidance that can be followed when the ESXi host boot process is stuck at "iscsi_vmk loaded successfully".

Symptoms:

  • During the ESXi host reboot, the boot process hangs at iscsi_vmk loaded successfully for a long time.
  • On the DCUI, you see the message "iscsi_vmk loaded successfully", but still the process does not proceed further even after waiting for a long time.



Environment

VMware vSphere ESXi

Cause

At this stage of the boot process, the ESXi host scans all the available target iSCSI luns assigned to it through all the paths configured from the host to the SAN. If there is no response from these paths, the ESXi boot process can become stuck at "iscsi_vmk loaded successfully" and it will not proceed further.

Resolution

The following describes the general troubleshooting steps that can be followed to isolate this issue further:
  • Press ALT+F12 on the DCUI of the host to view the vmkernel log messages and identify any underlying storage problems
  • Check for any underlying problems on the physical network
  • Check for any underlying problems on the storage array
  • Check for any underlying problems with a particular LUN or datastore on the array end
  • Verify there are no misconfigurations with ISCSI port binding, for more information see Considerations for using software iSCSI port binding in ESXi
If you are unable to isolate the cause from the ESXi console during boot, you can boot the ESXi host successfully by disconnecting the ISCSI network cables and rebooting the host.  After reboot, re-connect the cables and continue troubleshooting when you have full access to the ESXi shell.