VMware vCenter Site Recovery Manager service fails to start after changing the IP address of the SRM server
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VMware vCenter Site Recovery Manager service fails to start after changing the IP address of the SRM server

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Article ID: 308570

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:
  • Unable to start the VMware vCenter Site Recovery Manager (SRM) service.
  • SRM service fails to start after changing the IP address of the SRM server.
  • SRM service starts, but stops in few seconds.
  • In the vmware-dr-x.log file, you see the error:

    The proxy spec for extension com.vmware.vcDr points to Old_IP, not to this host


Environment

VMware Site Recovery Manager 5.1.x
VMware Site Recovery Manager 5.5.x

Cause

This issue occurs if the SRM extension continue to retain the old IP address.

Resolution

To resolve this issue, update the extension.xml file with the new IP address of the SRM server.

To update the extension.xml file:

  1. Open the extension.xml file using a text editor.

    Note: This file is located at C:\Program Files <x86>\VMware\VMware Site Recovery Manager\config\.


  2. Locate these entries within the file:

    <server>
    <url>http://Old_IP:8095</url>

    <client>
    <url>http://
    Old_IP:8096/VMware-srmplugin.exe</url>


  3. Change these entries to:

    <server>
    <url>http://New_IP:8095</url>

    <client>
    <url>http://New_IP:8096/VMware-srmplugin.exe</url>

  4. Save and close the file.
  5. Run this ccommand:

    C:\Program Files\VMware\VMware Site Recovery Manager\bin\srm-config -cmd updateext -cfg ../config/vmware-dr.xml –extcfg ../config/extension.xml


Additional Information

Impact/Risks: