Applying a host profile fails with the error: Resource group host/user/pool not found on system
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Applying a host profile fails with the error: Resource group host/user/pool not found on system

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Article ID: 308428

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Applying a host profile to a host fails
  • You see the error:

    Resource group host/user/pool<id> not found on system.


Environment

VMware vSphere ESXi 5.0
VMware vCenter Server 5.0.x

Cause

This issue can occur when:
  • There are resource pools on the vCenter Server
  • The host profile is created on a host where virtual machines are residing
  • The host profile has a folder called host/user/pool<id> that does not exist on another host

Resolution

You can resolve this issue by:
To modify the host profile:
  1. Log in to the vCenter Server via the vSphere Client.
  2. Navigate to Home > Management > Host Profiles.
  3. Select the host profile and click Edit Profile.
  4. Expand the host profile and navigate to Resource Pool.
  5. Expand Resource Pool, right-click the folder /host/user/pool<id> and click Remove Profile.
  6. Click OK.
To create a host profile from a host that does not have any virtual machines:
Note: This profile will not have the /host/user/pool<id> folder.
  1. Log in to the vCenter Server via the vSphere Client.
  2. Navigate to Home > Management > Host Profiles.
  3. Click Create Profile, select Create Profile from existing host and click Next.
  4. Select the host and click Next.
  5. Enter a name for the host profile and click Next > Finish.


Additional Information

For more information on applying a host profile, see Applying a Host Profile to a host or cluster (1010732). Applying a Host Profile to a host or cluster