Unable to connect to NFS server
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Unable to connect to NFS server

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Article ID: 308081

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Hosts become unresponsive while booting up
  • Cannot mount an NFS datastore
  • You cannot establish a connection to the NFS network share using the mount command from the ESX command line
  • You see these errors:
     
    • NFS Error: Unable to connect to NFS server
    • WARNING: NFS: 983: Connect failed for client 0xb613340 sock 184683088: I/O error
    • WARNING: NFS: 898: RPC error 12 (RPC failed) trying to get port for Mount Program (100005) Version (3) Protocol (TCP) on Server (xxx.xxx.xxx.xxx)
       
  • In the /var/log/VMkernel.log and /var/log/VMkwarning.log files, you see an entry similar to:

    NFS: 898, MOUNT RPC failed with RPC status 13 (RPC was aborted due to timeout) trying to mount Server
     
  • In the vobd.log file, you see an entry similar to:

    [esx.problem.vmfs.nfs.mount.connect.failed] Failed to mount to server <ip-address> mount point /<mountpoint>. Error: Unable to connect to NFS server.
     

    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.



Environment

VMware ESXi 6.x 

VMware ESXi 7.x

VMware ESXi 8.x

Cause

This issue occurs if there are problems related to network connectivity, permissions on the NFS Server, or firewall settings.

Resolution

To resolve this issue, ensure that there are no issues related to network connectivity, permissions on the NFS Server, or firewall settings:

Note: Run all commands in these steps from the ESXi/ESX command line with root access.
  1. Ensure that you can ping and vmkping the NFS server address.
  2. Ensure that any firewalls between the ESX host and NFS Server do not block the connection.
  3. Ensure the access on the NFS server is set to Anonymous user, Root Access (no_root_squash), and Read/Write.
  4. Restore the mount with this command:

    # esxcfg-nas -r
     
  5. Check to see if the datastore has mounted after trying to restore it with:

    # esxcfg-nas -l
     
  6. If it is not mounted, try remounting it using this command:

    # esxcfg-nas -a datastore_name -o nfs_server_hostname/ip -s mount_point

    Alternatively, add the datastore again using the vSphere client:
     
  7. Open firewall ports on the network for RPC protocol and check the physical switch for any RPC protocol filtering.

    Note: For security reasons, RPC protocol filtering is enabled, and the connection is refused.

On ESX hosts only (Does not apply to ESXi hosts):

  1. Check the ports open on the ESX firewall with this command:

    # esxcfg-firewall -q

    Note: Check the output for NFSClient. If it is not listed, proceed to step 9.
     
  2. Open the NFS client firewall ports 111 and 2049 on UDP and TCP protocol either on vCenter Server or on ESX with the command:

    # esxcfg-firewall --enableService nfsClient

    Alternatively, modify the security policy in vSphere Client. Click Configuration > Security Profile > Properties, select NFS Client and click OK.

    Note: Ensure that the ports 111 and 2049 are also open on the NFS server.
This issue can also occur if:
  • There is a misconfiguration on the Switch port. In this case, try using a different vmnic (or move NICs to Unused/Standby in the NIC teaming tab of the vSwitch or Portgroup properties).
  • The name of the NAS server is not resolved from the host side or vice versa. In this case, ensure that the DNS server and host-side entries are set properly.

If the preceding steps do not resolve the issue, see Troubleshooting NFS datastore connectivity issues