vCenter Server process (vpxd) consumes all memory and fails
search cancel

vCenter Server process (vpxd) consumes all memory and fails

book

Article ID: 307572

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • The VirtualCenter Server service (vpxd) consumes all the memory resulting in a spike.
  • The VirtualCenter Server service crashes after a few minutes with all guest operating system memory consumed.
  • Restarting vCenter Server does not fix this issue.
  • The vpxd.log (located at: C:\ProgramData\VMware\VMware VirtualCenter\Logs) contains entries similar to:

    24T10:01:56.027-04:00 [02708 info 'Default' opID=task-internal-38579-25b8ee9c] [VpxLRO] -- FINISH task-internal-38579 -- -- ScheduledTaskLRO --
    24T10:01:55.824-04:00 [11164 error 'Default' opID=task-internal-38505-4eda4232] [VpxdMail] Failed to send the mail to SMTP server (default) at port 25. Error=At least one of the From or Sender fields is required, and neither was found.
    -->


    ...

    24T09:22:40.083-04:00 [08288 info 'Default' opID=HB-host-13744@2072-e0b9d461] [ClientAdapterBase] InvokeOnSoap leaving
    24T09:22:40.380-04:00 [02616 info 'Default' opID=SWI-b36135d2] CoreDump: Writing minidump
    24T09:22:40.754-04:00 [02616 error 'Default' opID=SWI-b36135d2] CoreDump: Unable to write minidump
    24T09:22:40.785-04:00 [02616 error 'Default' opID=SWI-b36135d2] error -2147023441 : The paging file is too small for this operation to complete.
    24T09:22:40.785-04:00 [02616 panic 'Default' opID=SWI-b36135d2]

    Panic: Unable to allocate memory
    Backtrace:
    backtrace[00] rip 000000018013da0a (no symbol)
    backtrace[01] rip 00000001801006b8 (no symbol)
    backtrace[02] rip 0000000180100bbe (no symbol)
    backtrace[03] rip 000000018015f028 (no symbol)
    backtrace[04] rip 000000018015f131 (no symbol)
    backtrace[05] rip 000000018014eef0 (no symbol)


Environment

VMware vCenter Server 5.1.x
VMware vCenter Server 5.5.x

Cause

This issue occurs if an alarm's Trigger Status is configured to Unset, which results in a feedback response sending repeated SNMP traps to the email server. For example:
Status: Unset

Resolution

Currently, there is no resolution.
To work around this issue, ensure all active alarms in vCenter Server have their Triggers set to use one of these statuses:
  • Alert
  • Warning
  • Normal


Additional Information

To be alerted when this document is updated, click the Subscribe to Article link in the Actions box