vCenter Server shows gaps in performance data for some ESX/ESXi hosts
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vCenter Server shows gaps in performance data for some ESX/ESXi hosts

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Article ID: 307556

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • Performance data for some ESX/ESXi hosts is missing in vCenter Server.
  • Some hosts in vCenter Server have performance data, whereas others do not have performance data.
  • The time ranges of the missing data in different hosts do not match.
  • In the vpxd log files of vCenter Server, you see entries similar to:

    [2011-06-20 11:30:18.924 04584 error 'App'] Had to drop performance data coming from host host-252 because it has error (The specified network name is no longer available.)
[2011-06-20 11:35:00.017 03412 verbose 'App'] [VpxdMoHost::CollectRemote] Attempt to collect stats on host-252
[2011-06-20 11:35:00.017 03412 verbose 'App'] [VpxdMoHost::CollectRemote] Not collecting stats this time on host host-252 because collection pending


Environment

VMware vCenter Server 4.1.x
VMware vCenter Server 5.0.x

Cause

This issue occurs when there are intermittent network connectivity issues between the ESX/ESXi host(s) and vCenter Server. When vCenter Server attempts to collect performance statistics from a host that is not accessible, the statistics collection task is put into a pending state in vCenter Server and no further statistics collections tasks are issued against that host.

Resolution

This issue is resolved in VMware vCenter Server 4.1 Update 2 and VMware vCenter Server 5.0 Update 1.
Note: If you encounter this issue in VMware vCenter Server 5.0, subscribe to this document by clicking Subscribe to Document in the Actions box to be alerted when this article is updated for VMware vCenter Server 5.0.
To download vCenter Server 4.1 Update 2, see the VMware Download Center. For vCenter Server 5.0 Update 1, see the VMware Download Center.
When you do not want to upgrade to vCenter Server 4.1 Update 2 or vCenter Server 5.0 Update 1:
  1. Verify and ensure that there are no network connectivity issues that would affect the ESX/ESXi hosts.
  2. If you do not suspect network connectivity issues, investigate the health of the affected hosts.
  3. If you see Not collecting stats this time on host host-252 because collection pending messages in the vpxd logs, restart vCenter Server to force the statistics collection to resume for the affected hosts. For more information on restarting vCenter Server, see Stopping, starting, or restarting vCenter services (1003895).

Note: The issue may recur if there are other network connectivity issues between the host and vCenter Server. In this case, you must restart the VMware VirtualCenter Server service.


Additional Information

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