Upgrading to ESXi 5.x using Update Manager 5.x fails with error: "software or system configuration of host is incompatible"
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Upgrading to ESXi 5.x using Update Manager 5.x fails with error: "software or system configuration of host is incompatible"

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Article ID: 307366

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

  • Upgrading an ESXi 4.x host to ESXi 5.x using Update Manager 5.x fails
  • You see the error:

    software or system configuration of host is incompatible. check scan for details.

  • Upgrading an ESXi 4.x host to ESXi 5.x with vCenter Update Manager 5.x fails with the error:

    Cannot run upgrade script on host

  • In the /var/log/vua.log file on ESXi 5.x or /var/log/vmware for ESXi 4.1 and earlier, you see entries similar to:

    WARNING:root:Couldn't load esximage database: ('/bootbank/imgdb.tgz', "Failed to open tar database: [Errno 2] No such file or directory: '/bootbank/imgdb.tgz'."). Host may be incorrect version.

  • You are upgrading these software modules:

    • oem-vmware-esx-drivers-net-vxge (10 GB Neterion Network Card)
    • oem-vmware-esx-drivers-scsi-3w-9xxx (3Ware SCSU Network Card)

Environment

  • VMware ESXi 4.1.x Embedded
  • VMware vSphere ESXi 5.0
  • VMware vCenter Update Manager 5.0.x
  • VMware vSphere ESXi 5.1
  • VMware vSphere ESXi 5.5
  • VMware vSphere Update Manager 5.1.x
  • VMware ESXi 4.1.x Installable
  • VMware vSphere Update Manager 5.5.x

Cause

The compliance status may be incompatible when you perform an upgrade scan of ESX 4.1 Update 1 hosts against an ESXi 5.x upgrade baseline. The remediation of ESX 4.1 Update 1 hosts against an ESXi 5.x upgrade baseline may fail. The scan and remediation problems are caused by third-party drivers in the ESX 4.1 Update 1 installation. After an upgrade scan of hosts, more information about third-party software is provided in the conflict details for the upgrade baseline.

Resolution

To work around this issue, try these options in the order specified:

  • Workaround 1
  1. Reboot the affected host.
  2. Rescan the host against the existing baseline via Update Manager.
  3. Remediate the host via Update Manager.
  • Workaround 2
Check if the issue is caused by one of these types of drivers and perform the appropriate workaround:
    • Async drivers, such as oem-vmware-esx-drivers-scsi-3w-9### (3Ware SCSU Network Card).

      The vendor releases drivers asynchronously for ESXi 5.x, and the drivers are made available in the VMware patch depot.

      To work around this issue:
      1. Download the required drivers.
      2. Use Image Builder CLI to build a custom ESXi image which contains the required drivers.
      3. Remediate against the custom image.

        Note: Without the ESXi 5.x drivers, pertinent hardware devices may stop functioning.

    • Deprecated drivers, such as oem-vmware-esx-drivers-net-vxge (10 GB Neterion Network Card).

      The driver is discontinued in ESXi 5.x because the pertinent hardware is discontinued.

      To work around this issue:
      1. In the Update Manager Remediate wizard on the ESXi 5.x Upgrade page, de-select any installed third-party software that is incompatible with the upgrade.
      2. Continue with the remediation.

        Note: Be aware of the functional implications of third-party software removal, because pertinent hardware devices might stop functioning.
  • Workaround 3
Perform the upgrade using a scripted or interactive upgrade.

Additional Information

By using the Remediate wizard, you can ignore some upgrade scan warnings and force a remediation even if the upgrade warnings are not related to third-party software. On the ESXi 5.x Upgrade page of the Remediate wizard, you can remove installed third-party software that is incompatible with the upgrade and continue with the remediation to remove third-party software installed on the host and to ensure a successful remediation. Selecting the option also forces Update Manager to ignore three potential issues that are not related to third-party software.

These warnings are associated with the potential issues:
  • The root password is encrypted with DES encryption, causing it to be authenticated up to only 8 characters.
  • VMkernel and Service Console network interfaces are sharing the same subnet. This configuration is not supported after upgrade. Only one interface should connect to subnet. Unsupported devices <DEVICE_NAME></DEVICE_NAME>found on the host.
Before a remediation, perform an upgrade scan and review the messages in the Upgrade Details window of Update Manager. Take the necessary actions recommended by the messages to ensure that the remediation succeeds.