Booting ESXi 4.x embedded from USB key on IBM Blade fails with error: "Panic: No usable banks found."
search cancel

Booting ESXi 4.x embedded from USB key on IBM Blade fails with error: "Panic: No usable banks found."

book

Article ID: 307299

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

This article provides workaround information for this issue.

Symptoms:
  • Unable to boot ESXi 4.x embedded on an IBM blade.
  • Message displayed on the local console states:

    Cannot get bank 1 parameters.
    Warning: bank 1 partition type invalid. Ignoring.
    Cannot get bank 2 parameters.
    Warning: bank 2 partition type invalid. Ignoring.
    Panic: No usable banks found.

  • When disconnecting the HBA, ESXi loads and boots normally.
  • Recovery of the embedded installation with the IBM-provided CD does not fix the issue.
  • A live CD might not boot the host.


Environment

VMware ESXi 4.1.x Embedded
VMware ESXi 4.0.x Embedded

Cause

The ESXi embedded host is being presented LUNs by its HBA connected to the IBM BladeCenter.

The infrastructure increased in size and LUNs were made accessible to the host over a period of time where the host never been rebooted.

Resolution

The issue is due to how the default BIOS setup on the IBM Blade handles the presented LUNs.

In case of ESXi embedded the USB key containing the boot bank can have its drive ID changed while the system is not completely booted, making it impossible for the hypervisor loader to find its boot banks.

The issue is resolved by modifying the host BIOS setting Adapter Option ROM Support and disabling devices from which the host is not supposed to boot.

For example:
  1. Boot to <F1> Setup.
  2. Click Load Default Settings.
  3. Save settings.
  4. Press Enter.
  5. Click System Settings.
  6. Select Devices and I/O Ports.
  7. Enable/Disable ADAPTER OPTION ROM SUPPORT.
  8. Enable/Disable UEFI Option ROM(s).

Note: This issue may be resolved after disabling the Planar SAS option within ADAPTER OPTION ROM SUPPORT.


Additional Information

Hardware vendor support is the best point of contact to assess the situation and provide you help in setting up the host BIOS correctly.

Impact/Risks: