Site Recovery Manager UI displays "Unknown error. The latest version of Site Recovery UI is not available. Some functionality might be limited".
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Site Recovery Manager UI displays "Unknown error. The latest version of Site Recovery UI is not available. Some functionality might be limited".

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Article ID: 307247

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Updated On:

Products

VMware Live Recovery VMware vSphere ESXi

Issue/Introduction

Symptoms:

  • Site Recovery Manager UI displays the following error message:

“Site Recovery Manager - UI error: Unknown error. The latest version of Site Recovery UI is not available. Some functionality might be limited.”

  • vSphere Replication reconfigures successfully.
  • Site recovery manger/VLSR appliances reconfigures successfully.
  • Site Recovery UI appears functional.
  • Site pairing is successful and shows as connected.

 

 

Environment

  • VMware vSphere Replication 8.x
  • VMware vSphere Replication 9.x
  • VMware live site recovery 9.x
  • Site recovery Manager 8.x
 

Cause

  • This issue occurs due to stale or duplicate Site Recovery Web Client Plugin service registrations in the vCenter Lookup Service. These duplicate endpoints can cause conflicts, leading to the Site Recovery UI displaying an incorrect or incomplete version, even though functionality may not be impacted.

  • This issue can also occur if VC and SRM appliance cannot resolve their hostname. Please make sure VC can resolve configured SRM, vSphere replication hostnames.

 

Resolution

  • Please reconfigure VR/SRM appliances using IPs instead of hostname.
  • To identify and validate duplicate or stale Lookup Service registrations, perform the following steps:
  1. SSH to the vCenter Server Appliance.
  2. Run the below command to list all services registered with the Lookup Service:
    /usr/lib/vmware-lookupsvc/tools/lstool.py list --url http://localhost:7090/lookupservice/sdk --no-check-cert > /tmp/psc_services.txt
  3. Open /tmp/psc_services.txt and search for repeated entries for the Site Recovery Web Client Plugin (service type vrUi).
    Sample entries might look like the following:

 Name: VMware Site Recovery
        Description: Site Recovery Web Client Plugin
        Service Product: com.vmware
        Service Type: vrUi
        Service ID: h5-dr-3317d06b-4950-4c78-952d-xxxxxxx
        Site ID: sdc
        Owner ID: com.vmware.vr-3317d06b-4950-4c78-952d-xxxxxxx@vsphere.local
        Version: 8.1.1.10391544
        Endpoints:
 Name: VMware Site Recovery
        Description: Site Recovery Web Client Plugin
        Service Product: com.vmware
        Service Type: vrUi
        Service ID: h5-dr-d3037cbd-b35a-4b32-bf56-xxxxxxx
        Site ID: sdc
        Owner ID: com.vmware.vr-d3037cbd-b35a-4b32-bf56-xxxxxxx@vsphere.local
        Version: 8.1.1.10391544
        Endpoints:
 Name: VMware Site Recovery
        Description: Site Recovery Web Client Plugin
        Service Product: com.vmware
        Service Type: vrUi
        Service ID: h5-dr-6781d110-4f3f-47ab-8323-xxxxxxx
        Site ID: sdc
        Owner ID: com.vmware.vr-6781d110-4f3f-47ab-8323-xxxxxxx@vsphere.local
        Version: 9.0.2.24404698
        Endpoints:

Contact Broadcom Support to assist with deletion of stale or duplicate entries.

Deletion of service registrations directly impacts the Lookup Service, and improper deletion could affect environment stability. It is recommended to engage support for this task.