Logging into the vSphere Update Manager Utility fails with the error: Enter a valid server name
book
Article ID: 306766
calendar_today
Updated On:
Products
VMware vCenter Server
Issue/Introduction
Symptoms:
When you attempt to log into vSphere Update Manager Utility, it fails with the error:
Enter a valid server name
You are able to successfully log in when you use an IP address or only the vCenter Server host name (without a TLD extension) in the vCenter Server IP Address or Name field.
Logging in using an FQDN in the vCenter Server IP Address or Name field works when the top level domain (TLD) belongs to a defined set of well-known TLDs.
Environment
VMware vCenter Update Manager 5.1.x
Cause
This message is displayed if the specified FQDN does not end with a defined set of well-known top level domains (TLDs), such as .com or .org. TLDs such as .local or .corp, among others, are not part of this defined set.
Resolution
This functionality is incorporated into the VMware vSphere Update Manager Utility, and it is the expected behavior.
To work around this issue:
If the FQDN for your vCenter Server does not end with a well-known TLD, use the IP address or just the host name instead.