Slow vCenter Server performance after increasing the performance data statistics collection level to more than 2
search cancel

Slow vCenter Server performance after increasing the performance data statistics collection level to more than 2

book

Article ID: 306739

calendar_today

Updated On: 04-23-2025

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
After increasing the vCenter Server performance data statistics collection level to more than 2, you experience these symptoms in vCenter Server:

  • Performance is slow.
  • vpxd crashes and runs out of memory.
  • May see an event "Memory exceeds hard limit" in vpxd.log.
  • The VMware VirtualCenter Server service takes longer to start.
  • The vCenter Server database increases significantly in size.
  • The database transaction log increases significantly in size.
  • The performance data rollup jobs and stored procedures take a long time to run and may fail.
  • Performance graphs display gaps.
  • In the vpxd.log file, you may see this repeated entry:

    SQL execution took too long



Environment

VMware vCenter Server 8.x
VMware vCenter Server 7.x

Cause

When the statistic level are increased, a higher load is placed on vCenter Server and the amount of data which the vCenter Server rollup jobs need to process increases.

Resolution

Excepting the "Past Day" metrics, only statistics levels 1 and 2 are used for performance monitoring and analysis. Basic performance data are gathered at these levels. If you want to see more detailed information, you can view the statistics in real-time, which enables you to see every available metric without modifying the collection level.

In certain cases, you might want to record the more detailed metrics over a longer period of time. In this case, you can set a higher level for the desired duration and restore the level to a lower number after collecting the required information.

VMware strongly recommends you to not run at higher statistical collection levels for prolonged periods of time. Running at higher statistical levels is recommended only for a very short term and for test environments. 

 
To check the statistics levels:
  1. Log into the vSphere Client and select the vCenter Server object in the left navigation pane.
  2. Navigate to Configure > General > Edit > Statistics
  3. The level of statistics being stored for each Interval Duration can be seen or modified under Statistics Level.



Additional Information

More information about configuring statistics levels can be found in Configure Statistics Collection Intervals in the vSphere Client



Attachments

vCenter-4.1-DB-Size-Estimator.xlsx get_app
vCenter-2.x-DB-Size-Estimator.xls get_app