Setup window displays a blank screen when installing VMware Workstation
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Setup window displays a blank screen when installing VMware Workstation

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Article ID: 306634

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Updated On: 05-01-2025

Products

VMware Desktop Hypervisor VMware Workstation 6 (for Windows systems)

Issue/Introduction

  • During VMware Workstation installation, the Setup window goes blank.
  • Installation fails and presents an empty dialog box.
  • In the vmware.log file, you see the error:

    20100902170704:ERROR** CHtmlDialog::CallJScript: Failed to obtain required required jscript ID; COM Error: -2147352570

Environment

  • VMware Workstation 8.x (Windows)
  • VMware Workstation 6.x (Windows)
  • VMware Workstation Pro 12.x (Windows)
  • VMware Workstation 9.x (Windows)
  • VMware Workstation 10.x (Windows)
  • VMware Workstation 11.x (for Windows)
  • VMware Workstation 7.x (Windows)
  • VMware Workstation 5.x (Windows)

Cause

This issue may occur if:

  • The registry is damaged or modified
  • Files are missing
  • You have a video resolution problem

Resolution

Replace certain files with the original version.

Note: The steps in this article modify the Windows registry. Before making any registry modifications, ensure that you have a current and valid backup of the registry and the virtual machine. For more information on backing up and restoring the registry, see the Microsoft article 136393.

To replace the files:

  1. Open a command prompt. For more information, see Opening a command or shell prompt (1003892).
  2. Run these commands to re-register the necessary files and details:
     
    • If VMware Workstation is installed on a 32-bit version of Windows:
       
      1. regsvr32 jscript.dll
      2. regsvr32 vbscript.dll
         
    • If VMware Workstation is installed on a 64-bit version of Windows:
       
      1. cd C:\windows\syswow64
      2. regsvr32 C:\windows\system32\jscript.dll
      3. regsvr32 C:\windows\system32\vbscript.dll
         
  3. Restart Windows.
If these steps do not resolve the issue, edit the registry and enable ACTIVEX display:
  1. Click Start > Run, type regedit, and click OK.

    The Registry Editor window opens.
     
  2. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0.
  3. Right-click 1200 and click Modify.
  4. In the Value field, enter 0 or 1 and click OK.
  5. Quit the Registry Editor.
If changing the value to 0 or 1 fails to resolve the issue, browse to:
 
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\
 
In these locations, there are zones from 0,1,2,3, and 4. If you find a folder which has special characters in the name, delete the folder and then try installing.

Additional Information