Converting a machine in VMware vCenter Converter fails with the error: SQL_CANTOPEN: unable to open database file
search cancel

Converting a machine in VMware vCenter Converter fails with the error: SQL_CANTOPEN: unable to open database file

book

Article ID: 306624

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Converting a machine in VMware vCenter Converter fails.
  • You see the error:

SQL_CANTOPEN: unable to open database file

  • The worker.log contains errors similar to:

    YYYY-MM-DDT<time> [26408 error 'Default'] [task,362] [LRO] Unexpected Exception: SQL_CANTOPEN: unable to open database file
    YYYY-MM-DDT<time> [26408 info 'Default'] [task,379] [task-6] -- ERROR -- Convert: vmodl.fault.SystemError
    --> (vmodl.fault.SystemError) {
    --> dynamicType = <unset>,
    --> faultCause = (vmodl.MethodFault) null,
    --> reason = "SQL_CANTOPEN: unable to open database file",
    --> msg = "",
    --> }</time></time>


Cause

This error occurs when vCenter Converter is unable to access its internal database as the database file is locked.

Resolution

To resolve this issue, temporarily disable any third-party applications that may place a lock on the vCenter Converter database. In most cases, this is caused by a backup or antivirus solutions.

You may also prevent this from occurring by excluding the vCenter Converter database files from backup or antivirus scans located in:

C:\ProgramData\VMware\VMware vCenter Converter Standalone\db

or

C:\Documents and Settings\All Users\Application Data\VMware\VMware vCenter Converter Standalone\db