vMotion fails in one direction with the log error: bad0020
search cancel

vMotion fails in one direction with the log error: bad0020

book

Article ID: 306600

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • vMotion between two hosts works in one direction (for example, from ESX1 to ESX2), but fails in the other direction (for example, from ESX2 to ESX1)
  • The vMotion operation fails at 10%
  • You see the following error reported in the vSphere client:

    A general system error occurred: Migration failed while copying data. Not Supported.
  • The vmkernel.log files contain entries similar to:

    (cat /var/log/current_vmkernel_or_messages_log | cut -d ")" -f 2- | grep -A3 -i vmotionrecv)
    VMotionRecv: 1589: 1255000435466375 S: Error handling message: Not supported
    WARNING: Migrate: 295: 1255000435466375 S: Failed: Not supported (0xbad0020) @0x0
    WARNING: Migrate: 2545: 1255000435466375 S: Migration has failed; failing memory pre-copy attempt.
    WARNING: Migrate: 3267: 1255000435466375 S: Migration considered a failure by the VMX. It is most likely a timeout, but check the VMX log for the true error.
  • The vmware.log files contain entries similar to:

    (cat /vmfs/volumes/*/*/vmware.log | cut -d "|" -f 2- | grep -i setfailure)
    Migrate_SetFailure: Failed waiting for data. Error bad0020. Not supported.
  • The hostd.log files contain entries similar to:

    (cat /var/log/current_hostd_log_file | cut -d "]" -f 2- | grep -B4 -i vmotionlaststatuscb)
    Question info: Migration to host <<unknown>> failed with error Not supported (0xbad0020).
    , Id: 1 : Type : 3, Default: 0, Number of options: 1
    Retrieved current VM state from foundry 4, 8
    VMotionResolveCheck: Operation in progress
    VMotionLastStatusCb: Failed with error 536870944: Migration failed while copying data. Not supported.
Note: Depending on the version of ESX/ESXi being used, the log file names and directory locations may be different. For more information, please see Location of log files for VMware products (1021806).


Environment

VMware vCenter Server 4.1.x
VMware ESX 4.1.x
VMware ESX 4.0.x
VMware ESXi 4.0.x Embedded
VMware ESXi 4.1.x Embedded
VMware ESXi 4.1.x Installable
VMware ESXi 4.0.x Installable
VMware vSphere ESXi 5.0
VMware vCenter Server 5.0.x
VMware vCenter Server 4.0.x

Cause

This issue occurs when the dvsdata.db file is corrupted (typically on the destination ESX/ESXi host).
This issue may occur even if you are not using vNetwork Distributed Switches (vDS) in your ESX/ESXi environment.

Resolution

To determine if the dvsdata.db file is corrupted, run the command:
# /usr/lib/vmware/bin/net-dvs
If the dvsdata.db is corrupted, you see the output:
failed to get config data: Not initialized.
Note: If no output is returned, then vDS is not enabled.
To resolve this issue:
  1. Download and unzip 1015322_dvsdata.zip (attached to this article). This zip file contains an uncorrupted copy of dvsdata.db.

    Note: You can also obtain an uncorrupted dvsdata.db from an ESX/ESXi host in your environment which is not experiencing this issue.
  2. Replace the corrupt dvsdata.db in /etc/vmware/ with the uncorrupted file.
  3. Reboot the host.
  4. Run the following command to verify that the file is no longer corrupted:

    # /usr/lib/vmware/bin/net-dvs

Alternately, you can use this command to reload dvsdata.db without a reboot:

# /usr/lib/vmware/bin/net-dvs -S /etc/vmware/dvsdata.db


Additional Information

Location of log files for VMware products

Attachments

1015322_dvsdata.zip get_app