Upgrading VMware Workstation, Player, or VMware Tools in a virtual machine fails with the error: CDS Internal Client Error (3033)
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Upgrading VMware Workstation, Player, or VMware Tools in a virtual machine fails with the error: CDS Internal Client Error (3033)

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Article ID: 306459

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Updated On:

Products

VMware Desktop Hypervisor

Issue/Introduction

Symptoms:
  • Cannot upgrade VMware Workstation, Player, or VMware Tools using the built in updater
  • Upgrading VMware Workstation by clicking Help > Software Updates > Check for updates fails
  • The following error is seen:
    CDS Internal Client Error (3033)

Environment

VMware Workstation 17.5x

Cause

This issue occurs when the update server cannot be reached, or is experiencing issues that impacted the service when the upgrade was attempted.

Resolution

  1. Ensure that you are connected to the Internet. If the physical machine is not able to connect to the Internet, there will be network connectivity issues.
  2. Disable any firewall installed on the physical machine. Firewall programs may block the VMware Workstation updater from reaching the update server.
  3. Go to Start > Run and type %temp% to clear the temporary folder.
  4. Quit VMware Workstation or Player software.
  5. Reboot the physical machine.
  6. Start Workstation or Player and retry the upgrade.
Try downloading the full installer for the recent version of VMware Workstation from the VMware Web site and perform the upgrade manually. To download and install/upgrade the product manually:
  1. Exit VMware Workstation.
  2. Download the most recent version of VMware Workstation at VMware Download Center
  3. Install VMware Workstation. For more information, refer to the user manuals available at VMware Workstation Documentation
  4. Restart the physical machine.
  5. Launch VMware Workstation.