"scafirstboot" service Firstboot fails when upgrading vCenter Server 6.7
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"scafirstboot" service Firstboot fails when upgrading vCenter Server 6.7

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Article ID: 305926

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • In the firstbootStatus.json file, you see the error:
"failedSteps": "scafirstboot"
 
  • In the scafirstboot.py_####_stderr.log file, you see the error:
Entry with name serviceId: #######-####-####-####-######### not found


Note: 

  • vCenter Server on Windows - Firstboot logs are located in the VMware-VCS-logs-<year><month><day><hour><minute><second>.zip/vcs_logs/uninstall directory or the VMware-VCS-logs-<year><month><day><hour><minute><second>/vcs_logs/uninstall/<vCenter Hostname><year><month><day><hour><minute><second>.zip/ProgramData/VMware/vCenterServer/logs/firstboot directory.

Environment

VMware vCenter Server 6.7.x

Cause

This issue occurs during upgrades that involve any patched build of vCenter Server on Windows 6.5 to vCenter Server on Windows 6.7.  Legacy service registration entries were not cleared during major upgrades.

Resolution

This issue is resolved in vCenter Server 6.7 U1.

Workaround:
Remove the problematic SCA registration entry.

  1. Created backup of file: scaspec.properties
Note:
  • scaspec.properties is located in the C:\Program Files\VMware\vCenter Server\sca\conf directory.
  1. Edit scaspec.properties file.
  2. Remove the entire line referencing the old service ID.
Note:
  • The old service ID will be presented during the error message.  It can also be found in the scafirstboot.py_####_stderr.log log.  See symptoms for more details on log locations.
  1. Save the file. 
  2. Upgrade to vCenter Server 6.7.

Additional Information