Hosts appear as not responding in vCenter Server 5.0.x with a large number of datastore
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Hosts appear as not responding in vCenter Server 5.0.x with a large number of datastore

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Article ID: 305806

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • Hosts appear as not responding in vCenter Server 5.0.x.
  • Hosts display the Host connection failure alarm.
  • The vpxd.log displays entries similar to:

    YYYY-MM-DD Time [05868 verbose 'Default'] [ComputeDatastoreAggregateStat] Stats polling took [0] ms

    YYYY-MM-DD Time [04908 verbose 'Default'] [ComputeDatastoreAggregateStat] Stats polling took [5] ms

    YYYY-MM-DD Time [06336 error 'vmomi.soapStub[270]'] Resetting stub adapter for server TCP:vc-name:443 : service state request timed out after 60 second

    VpxdMoDatastore::ComputeDatastoreAggregateStatdatabase error

    Note
    : The default location for vpxd.log is C:\ProgramData\VMware\VMware VirtualCenter\Logs.


Environment

VMware vCenter Server 5.0.x

Cause

When vCenter Server inventory contains a large number of datastores (greater than 300), it may consume a large amount of system resources while computing the datastore statistics. The lack of resources may cause vCenter Server to fail to respond to other administrative tasks, including the host heartbeat information sent from ESX/ESXi hosts. In such a case, the host disconnects and triggers the corresponding connection alarms.

Resolution

This issue is resolved in vCenter Server 5.0 Update 1 and later, available at VMware Downloads.

For more information, see the vCenter Server 5.0 Update 1 Release Notes..


Additional Information

多数のデータストアが登録されている vCenter Server 5.0.x でホストが応答なしと表示される