Virtual machine loses network connectivity to the vNetwork Distributed Switch after a reboot or power cycle
search cancel

Virtual machine loses network connectivity to the vNetwork Distributed Switch after a reboot or power cycle

book

Article ID: 305595

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • One or more virtual machines lose network connectivity to the vNetwork Distributed Switch (vDS) after a reboot, a power cycle, or a vMotion live migration to another host.
  • The virtual machine is connected to the vDS.
  • In the hostd.log file of the ESX/ESXi host and the vmware.log file of the virtual machine, you see an error similar to:
Failed to connect ethernet0.
  • In the hostd.log file, you see entries similar to:
[2012-09-23 20:06:08.977 F62BFB90 info 'NetworkProvider'] Setting connectionId to 0 for port 82 32 26 50 30 1b 42 f1-c2 bc 3a e7 0c 01 6b 13-227
  • When running the net-dvs command, you may see a line stating that connectid = 0

    For example:
com.vmware.common.port.connectid = 0


Environment

VMware vCenter Server 4.0.x

Cause

This issue occurs because vCenter Server pushes a connection cookie to the dvPort with a value of 0 when a dvPort conflict is detected. A dvPort conflict can occur when when a virtual machine comes online with the same dvPort as an existing virtual machine to your vCenter Server inventory. After this conflict occurs, vCenter Server clears the connection cookie with a NULL value and then pushes the 0 value to the host when there are any further dvPort configuration changes.

Note: This issue occurs only in vCenter Server 4.0 and does not impact vCenter Server 4.1 or later versions.

Resolution

To resolve this issue, upgrade to vCenter Server 4.1 or later.
To download vCenter Server 4.1 or later, see the VMware Download Center.
To work around this issue when you do not want to upgrade:
  1. Reconfigure the virtual machine to move its network adapter from the current vDS to another vDS or to a Standard Virtual Switch portgroup and apply the settings.
  2. Configure the virtual machine to connect back to the original vDS and then assign a new port number.

    The network connectivity should now be restored.