vCenter Service Status shows blank screen
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vCenter Service Status shows blank screen

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Article ID: 305583

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Updated On:

Products

VMware vCenter Server

Issue/Introduction


Symptoms:

When you log in to vCenter Server through vSphere Client and navigate to Administration > vCenter Service Status, you encounter one of these:

  • A blank screen

    OR

  • A dialog box displaying:

    An error has occurred in the script on this page Internet Explorer script error.

    Clicking Yes in the dialog box results in a blank vCenter Service Status screen

    OR

  • This error:

    Unexpected exception in locale detection, using default: [object Error]error message.


Environment

VMware vCenter Server 4.0.x

Cause

This issue can occur due to a web services error caused by not obtaining host information from the host servers. If web services has an issue with Tomcat running or websites not being entered into IE on the vCenter server, the vCenter server cannot pull the requested information.

For more information on this issue, see the vCenter Server, vSphere Client, and vSphere Web Access Known Issues in the VMware vCenter Server 4.0 Update 1 Release Notes.

Resolution

Note: Before carrying out this workaround, determine whether a refresh of the vCenter Server status addresses the issue or if stopping the vSphere client in Task Manager and logging in again addresses the issue as outlined in the VMware vCenter Server 4.0 Update 1 Release Notes.

If you cannot resolve this issue by refreshing the status or restarting the client, add both the vCenter Server and the address of the vCenter Service Status page as trusted internet sites.

To add the vCenter Server as a trusted site:

  1. Open Internet Explorer.
  2. Go to Tools > Internet Options and click the Security tab.
  3. Select Trusted sites.
  4. Enter the vCenter Server's short name as a trusted site and click OK.
  5. Click OK again to close the Internet Options window.

To add the address of the vCenter Service Status page as a trusted site:

  1. Obtain the address of the vCenter Service Status page:
    1. Refresh the vCenter Service Status page.
    2. Copy the address of the web page that is causing the IE script issue.

  2. Add the copied address to Internet Explorer's list of trusted sites:
    1. Open Internet Explorer.
    2. Go to Tools > Internet Options and click the Security tab.
    3. Select Trusted sites.
    4. Enter the vCenter Server's short name as a trusted site and click OK.
    5. Click OK again to close the Internet Options window.

When you refresh the vCenter Service Status page, it now displays correctly.

Note: In some cases, the Internet Explorer script error reappears even after you click Yes repeatedly, and the blank screen is not displayed. When this happens, stop the vSphere Client application in Task Manager, and log in again.

If exiting and restarting the vSphere client does not address the issue, un-install and re-install the vSphere client.


Additional Information

Note: This resolution may also resolve the search function not working in vCenter Server and other functions relying on Web Services to pull information from the hosts.