When using VMware Service Manager you see the error: There was no endpoint listening
search cancel

When using VMware Service Manager you see the error: There was no endpoint listening

book

Article ID: 305452

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:

When attempting to log as WSTESTER to test API transactions in VMware Service Manager, you receive this error:

There was no endpoint listening at http://localhost/Infra.API.Service/ServiceManager.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.


Environment

VMware Service Manager 9.x

Resolution

This issue occurs if the endpoint address to which the API test application will connect is not configured.

To resolve this issue and use the API test application, you must first configure the end oint address, to which the application connects.

To configure the endpoint address:

  1. Navigate to this folder:

    <installation directory>\EMC\VMware Service Manager\<system name>\WStester

  2. Open the web.config file in a text editor, such as Notepad.
  3. In the web.config file, change the endpoint address (located at the bottom of the file) so it points to the VMware Service Manager web service.

    Example: If the service is on the same machine, change the line:

    <endpoint address = 'http://localhost/Standard90/ServiceManager.svc'>

  4. For more information see the VMware Service Manager v9.0 API User Guide.