ESXi 5.0 fails to respond or is disconnected from vCenter Server because of the locked esx.conf file
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ESXi 5.0 fails to respond or is disconnected from vCenter Server because of the locked esx.conf file

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Article ID: 305118

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • ESXi 5.0 host is not responding or is disconnected from vCenter Server
  • Attempting to log in to the host using Tech Support mode (either from the DCUI or SSH) fails
  • There are no indications of a storage issue in the vmkernel.log system log file
  • The esxtop command indicates that processes, such as esxcfg-advcfg or DCUI, are consuming 100% of the CPU
  • Attempting to restart the management agents fails
  • In the hostd.log file, you see entries similar to:

    2012-02-12T19:21:11.950Z cpu14:9379)WARNING: Tcpip: 1308: socreate(type=2, proto=0) failed with error 55

  • All virtual machines are working properly




Environment

VMware vSphere ESXi 5.0

Cause

This issue occurs when a process locks the /etc/vmware/esx.conf file and does not release the lock, causing the next process that attempts to update and lock the file to fail.

When updating the ESX configuration (and thus the esx.conf configuration file), you create a lock file /etc/vmware/esx.conf.LOCK and link it to the process attempting to lock the file. If the link (known as a symlink) is not valid, it prevents the esx.conf from being unlocked.

Resolution

This issue is resolved in the ESXi 5.0 patch released on July 12, 2012. For more information, see VMware ESXi 5.0, Patch ESXi500-201207401-BG: Updates esx-base (2019108).

To work around this issue when you do not want to apply the patch, remove the symlink and restart the management services.
To remove the symlink:
  1. Log in to the Local Tech Support Mode console of the ESXi host. For more information, see Using Tech Support Mode in ESXi 4.1 and ESXi 5.0 (1017910).
  2. Confirm that there is a symlink file on the host using the ls command:

    # ls -l /etc/vmware/esx.conf.LOCK

  3. Run this command to remove the symlink file:

    # rm /etc/vmware/esx.conf.LOCK

  4. Run this command to restart the management agents:

    # /sbin/services.sh restart

    For more information on restarting management agents, see Restarting the Management agents on an ESX or ESXi Server (1003490).
Note: If this issue recurs on your host, use the script in the 2014077_RemoveBrokenSymlink.zip file attached to this article, which removes the locked file in a CRON job and schedule it to run at a regular frequency, such as 30 minutes. For more information, see Gathering esxtop performance data at specific times using crontab (1033346)


Additional Information

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Restarting the Management agents in ESXi
Using Tech Support Mode in ESXi 4.1, ESXi 5.x, and ESXi 6.x
Gathering esxtop performance data at specific times using crontab
VMware ESXi 5.0, Patch ESXi500-201207401-BG: Updates esx-base
ロックされた esx.conf ファイルが原因で、ESXi 5.0 が応答しないか、vCenter Server から切断される

Attachments

2014077_RemoveBrokenSymlink.zip get_app