Restore Defaults to resolve corruption or errors
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Restore Defaults to resolve corruption or errors

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Article ID: 30510

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The view for one or more users gets broken, resulting in a system error when you navigate to it. How do you restore defaults in Clarity to resolve the issue with the view, portlet, or page?

Symptoms include:

  • Error: System error. Contact system administrator instead of data on the page.
  • Other types of page corruptions such as buttons ( Save, Save and Return, or other buttons) or icons missing.
  • The Configure link is missing from the Cogwheel/Options menu.
  • Unable to see data in filter results even though you have proper access.
  • The app-ca logs throw an error similar to: ORA-04036: PGA memory used by the instance exceeds PGA_AGGREGATE_LIMIT
  • The page does not load and error: Unable to process request - Server or Network error is thrown

Types of pages this can happen on include:

  • Portlets (Resource Planning, etc)
  • List views (such as Tasks, Projects)

Environment

Release: All Supported Releases

Cause

Corruption of the view. One way this can happen is if you have fields in the view that no longer exist in Clarity

Resolution

Log in as the user with the issue and Restore Defaults on the impacted portlet/list view. Use one of the options below to do this. 

Fiddler

Fiddler can be used to retrieve the needed URL to restore defaults. This is needed when Clarity does not reflect the link for the Restore Defaults page in the URL.

  1. Install the Fiddler tool. The link to download this can be found at: https://www.telerik.com/download/fiddler.
  2. Log in to Clarity as a user who does NOT have the issue.
  3. Navigate to the page where the user is facing the issue.
  4. Launch Fiddler.
  5. Once Fiddler is open, go back to Clarity and click on the Options icon in the upper right-hand corner, then select Configure.
  6. Go to Fiddler and click on the last link, which should be the trace for navigating to the configure page in Clarity.
  7. In the request headers section, copy everything after "action=" and prior to "HTTP/1.1".
  8. Log in as the user with the issue.
  9. Take the data you just copied from Fiddler and paste it in the Clarity URL after "action:".
  10. This will take you to the List Column Layout view.
  11. It’s recommended to take a screenshot of the view you see on the List Column – Section for two reasons:
    • This will help in troubleshooting to determine if a particular field you added is causing the issue.
    • Since restoring defaults removes your customizations, taking a screenshot will enable you to reconfigure your view after restoring defaults
  12. Click on the General tab, then click Restore Defaults.
You may get system errors when trying to go directly to the General tab from Fiddler, so that is why it's recommended to take the Fiddler URL directly after clicking Configure.
This places you on the List Column - Section page and not on the General tab.  

Create a bookmark (Firefox)

  1. In Firefox, log in to Clarity as a user that doesn't have the issue.
  2. Navigate to the portlet page with the issue.
  3. Right-click on the configure link and select "bookmark this link".
  4. Log in to Clarity as the user with the issue and select the bookmark.
  5. This will bring you to the configure portlet page where you can restore defaults as the user with the issue.

Developer tools (IE or Chrome)

  1. Log in to Clarity with a user ID that doesn't have the issue. 
  2. Navigate to the portlet/list page with the issue.
  3. Click F12 on your keyboard
  4. While the Network tab is open, click on the Options icon on the portlet/list view, and then on Configure
  5. On the Developer Tools window, right-click on the URL populated, and select the option to 'Copy URL'
  6. Paste the URL on a notepad, and then only copy everything after 'action='
    For example, the copied URL to the project list view will look something like:

    http://clarityURL/niku/nu?uitk.vxml=1&action=npt.filterUserLayoutEntry&ui.page.space=mainnav.work&ui.page.template=union.appPage&url=/niku/app%3Faction%3Dprojmgr.projectList%26classCode%3Dproject&pageId=projmgr.projectList&portletInstanceId=projmgr.projectList_odf&object=project&component=projmgr&id=projmgr.projectList&view_code=projectList&filter_view_code=projectList&isFilter=true

    Then copying only after the 'action=':

    npt.filterUserLayoutEntry&ui.page.space=mainnav.work&ui.page.template=union.appPage&url=/niku/app%3Faction%3Dprojmgr.projectList%26classCode%3Dproject&pageId=projmgr.projectList&portletInstanceId=projmgr.projectList_odf&object=project&component=projmgr&id=projmgr.projectList&view_code=projectList&filter_view_code=projectList&isFilter=true

  7. Paste what was copied to the right of the 'action=' on the existing Clarity URL after 'action:'
    For example, the existing PPM URL when on the Project list will look like:

    http://clarityURL/niku/nu#action:projmgr.projectList&classCode=project

    Replacing the content after the 'action:', with the content after the 'action=' on Step7, the resulting URL would be: 

    http://clarityURL/niku/nu#action:npt.filterUserLayoutEntry&ui.page.space=mainnav.work&ui.page.template=union.appPage&url=/niku/app%3Faction%3Dprojmgr.projectList%26classCode%3Dproject&pageId=projmgr.projectList&portletInstanceId=projmgr.projectList_odf&object=project&component=projmgr&id=projmgr.projectList&view_code=projectList&filter_view_code=projectList&isFilter=true

  8. Log in as the user with the issue.
  9. Paste the resulting URL obtained in Step in 7 in the URL bar. This will take the user to the List Column Layout page of the Configure options for the portlet/view.
  10. To restore the view, click on the General tab and click on Restore Defaults.

Additional Information

See also: Clarity frequently reported issues

Additional Steps Taken if problem persists:

a. Delete any saved filter views.
b. Click Manage to remove all fields but one on the List  Column Section > Layout
c. Click Manage to remove all fields but one on the List Filter Section > Layout
d. Click Save
e. Clear browser cache, log out and log back in