Watch4net: Cannot delete metrics in APG Management of Database Metrics module
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Watch4net: Cannot delete metrics in APG Management of Database Metrics module

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Article ID: 304674

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Cannot delete metrics in Watch4net APG Management of Database Metrics module
The following message is received in the Watch4net APG Management of Database Metrics module when a metric is selected and the Delete button is clicked:

Some errors occurred. See logs for details.

Connection error.
The catalina log (/opt/APG/Web-Servers/Tomcat/Default/logs/catalina.YYYY.MM.DD.log) shows the following:

Mar 12, 2013 3:37:31 PM com.watch4net.apg.v2.gui.servlet.form.DataManagementServlet d

WARNING: Variable Management Unexpected connection error.

java.net.ConnectException: Connection timed out



Environment

VMware Smart Assurance - Watch4Net/M&R

Cause

The APG.xml file is not configured with the correct access to the backend.

Resolution

The Management of Database Metrics module accesses the backend directly to delete metrics from the database. The APG.xml file needs to be configured to point to the backend hosts IP address and ports:

Linux/Solaris:   
/opt/APG/Web-Servers/Tomcat/Default/conf/Catalina/localhost/APG.xml

Windows:        
C:\Program Files\APG\Web-Servers\Tomcat\Default\conf\Catalina\localhost\APG.xml

APG.xml file configuration

        <!--
                Data management tool needs to communicate with the timeseries backend. Please define one entry per
                available timeseries database, with the same name (ex: jdbc/APG-DB -> mgmt/APG-DB).
        -->
        <Resource name="mgmt/APG-DB" factory="org.apache.naming.factory.BeanFactory"
                type="com.watch4net.apg.v2.modules.admin.BackendCommunication" backendHost="ip-address-of-backend-host"
                backendTelnetInterfacePort="2001" backendSocketInterfacePort="2000" />