Watch4Net: LDAP authenticated users are unable to log in; Tomcat catalina log contains login-related errors
search cancel

Watch4Net: LDAP authenticated users are unable to log in; Tomcat catalina log contains login-related errors

book

Article ID: 304636

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:




LDAP authenticated users are unable to log in to Watch4Net
The following error messages are seen in the tomcat catalina log for Watch4Net environment:

Feb 18, 2013 11:42:28 AM com.watch4net.apg.v2.gui.tomcat.LoggingValve logError
SEVERE: Attempt to login to tomcat realm as 'user-account' has failed from 'x.x.x.x'.

Feb 18, 2013 11:44:49 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Realm/Realm} Setting property 'userSubTree' to 'true' did not find a matching property.



Environment

VMware Smart Assurance - Watch4Net/M&R

Cause

This issue is seen when the user account that is used by tomcat to authenticate with the external LDAP environment is locked out. This can occur because the password has expired or some other change has been made to that user account.

Resolution

To resolve the issue, ensure that the account is active and valid and that the correct account details are configured in the Watch4net APG server.xml file (<APG_DIR>/Web-Servers/Tomcat/Default/conf/server.xml).