连接到 SRM 5.0 Server 失败并出现错误:The remote server returned an error: (503) Server Unavailable
search cancel

连接到 SRM 5.0 Server 失败并出现错误:The remote server returned an error: (503) Server Unavailable

book

Article ID: 304516

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction


Symptoms:
免责声明:本文为 Connecting to SRM 5.0 server fails with the error: The remote server returned an error: (503) Server Unavailable (2012112) 的翻译版本。尽管我们会不断努力为本文提供最佳翻译版本,但本地化的内容可能会过时。有关最新内容,请参见英文版本。


在 vCenter 5.0 和 Site Recovery Manager 安装在同一服务器上的 Windows 2008 R2 Server 上安装 Windows Update 后,观察到以下症状:
  • 无法使用 vSphere Client 中的插件登录到 Site Recovery Manager (SRM) 5.0。
  • 显示以下错误:

    Lost connection to SRM Server 10.10.10.12:8095
    The server '10.10.10.12' could not interpret the client's request. (The remote server returned an error: (503) Server Unavailable.)
    Connecting ...

  • SRM vmware-dr.log 文件包含以下错误:

    YYYY-MM-DDT09:1:16:16.425-05:00 [06012 warning 'LocalVC'] Failed to connect: (vim.fault.InvalidLogin) {
    --> dynamicType = <unset>,
    --> faultCause = (vmodl.MethodFault) null,
    --> msg = "Cannot complete login due to an incorrect user name or password."

    注意:有关详细信息,请参见 Location of Site Recovery Manager log files (1021802)


Cause

导致此问题发生的原因可能有多个:
  • 确认 Active Directory 中的 Site Recovery Manager 用户帐户未锁定,自 SRM 安装后未更改用户的密码,并且密码设置为不过期。
  • Site Recovery Manager 服务可能未在运行。检查 SRM Server 上的服务以确保 Site Recovery Manager 服务正在运行。

Resolution

要在用户密码已更改时解决此问题,请确保更新 SRM 中存储的密码。
要更改存储的密码,请执行以下操作:
注意:在某些情况下,可能需要重新安装 SRM,并重新指向原始数据库才能解决该问题。


Additional Information

Connecting to SRM server fails with the error: The remote server returned an error: (503) Server Unavailable