vSphere Client reports "no healthy upstream" after installing VCSA 7.x
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vSphere Client reports "no healthy upstream" after installing VCSA 7.x

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Article ID: 304357

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • Cannot access vSphere Client after installing vCenter Appliance 7.0. vSphere Client fails to load with the error, "no healthy upstream".
  • You are able to access the vCenter Appliance Management Interface over port 5480



Environment

VMware vCenter Server 7.x

Cause

The Appliance is missing localhost in /etc/hosts file, or /etc/resolv.conf does not have proper DNS servers listed.

/etc/resolv.conf should have primary and secondary DNS servers per install, and this can be manually changed by editing this file post install if that does change and VAMI is not accessible.

/etc/hosts should originally look similar to:

# End /etc/hosts (network card version)
# VAMI_EDIT_BEGIN
# Generated by Studio VAMI service. Do not modify manually.
##.##.##.## <server name>.example.com <server name> <server name>
##.##.##.## <server name>.example.com <server name> <server name>
# VAMI_EDIT_END

Resolution

Take a backup of the /etc/hosts file before making any changes.

Modify /etc/hosts file by adding  localhost. It should look similar to the below:
 

# End /etc/hosts (network card version)
# VAMI_EDIT_BEGIN
# Generated by Studio VAMI service. Do not modify manually.
127.0.0.1 <server name>.example.com <server name> localhost
::1 <server name>.example.com <server name> localhost ipv6-localhost ipv6-loopback
# VAMI_EDIT_END

Additional Information

Skyline Health Diagnostics can be used to detect and provide remediation to issues in the vSphere and vSAN

https://knowledge.broadcom.com/external/article/345059/vmware-skyline-health-diagnostics-for-vs.html