Smarts SAM: SAM Presentation server domain log file contains "Unknown fieldName: in ics-nl-processing.asl" error
search cancel

Smarts SAM: SAM Presentation server domain log file contains "Unknown fieldName: in ics-nl-processing.asl" error

book

Article ID: 304340

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:



 

The following error is seen in the Smarts Service Assurance Manager (Smarts SAM) Presentation server domain log file:

Unknown fieldName: in ics-nl-processing.asl

 

The following error is seen in the Smarts SAM environment: 

SAM-AGG_NL-Driver-HyperNotif ASL_MSG-*-ASLP-ics/ics-nl-processing.asl: Unknown fieldName: in ics-nl-processing.asl



Environment

VMware Smart Assurance - SMARTS

Cause

Invalid characters exist in the dxa file that was edited. The above issue was observed in an environment that had invalid space bar entries in the dxa-sam.conf file.

Resolution

If you encounter this issue, do the following:

  1. Execute the following comamnd from the <SAMBASEDIR>\smarts\bin directory:

    dmctl -s <SAM-PRES-DOMAIN> getI GA_DaemonDriver

    Output example

    <SAM-AGG-DOMAIN>_NL-Driver-HyperNotif

     
  2. Execute the following command from the same directory:

    dmctl -s <SAM-PRES-DOAMIN> get GA_DaemonDriver::<SAM-AGG-DOMAIN>_NL-Driver-HyperNotif " more

     
  3. Using sm_edit, open the dxa-sam.conf file located in the following directory: 

    <BASEDIR>\SAM\smarts\local\conf\ics
     
  4. Look for the following character for invalid space bar entries in the dxa-sam.conf file:
     
  5. Inspect the file for other invalid characters that should not be present.
  6. Edit the dxa file and remove all invalid characters.
  7. Save and close the dxa-sam.conf file.
  8. In Global Manager Admin Console, run reconfigure operation. 
  9. Inspect log and confirm the errors are no longer present.