Smarts SAM: Notif is not processing traps from Smarts topology items
search cancel

Smarts SAM: Notif is not processing traps from Smarts topology items

book

Article ID: 304298

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Notif is not processing traps from devices in the Smarts Service Assurance Manager (Smarts SAM) topology
Smarts trap adapter, the Smarts OI domain, and Notif have all been configured correctly but Notif is not processing traps

Environment

VMware Smart Assurance - SMARTS

Cause

Assuming that the Smarts SAM trap adapter, Smarts OI domain, and Notif have all been configured correctly to process traps, there are a few reasons why it may seem that Notif is not processing a trap:

  • The trap already has an active notification in Smarts OI and the current notification has not yet been Cleared.
  • The trap is coming from or configured to indicate it came from a device in the Smarts topology not capable of sending the trap.

The reasons that the trap will not be processed in these cases include:

  • The trap should be processed but a new notification should not be generated. Instead, if the event is configured to be 'Momentary', the count of the current notification should increase on the Smarts SAM domain that is subscribed to OI. If the event is set to 'Durable' then nothing will happen.
     
  • The ElementClassName that is configured in Notif for the trap does not match the class of the device in the Smarts topology (i.e.  A trap Router coming from a device listed as a Host).

Resolution

Possible solutions to this issue include:

  • Ensure that a Clear is sent to the OI by the trap before a new trap is sent, and be sure there is a Clear trap configured in the Notif.
  • If you set the ElementClassName to the 'UnitaryComputerSystem' then you can set the ClassName to anything class you want in the ECI.  The trap should notify and should show as coming from the class you set ClassName to, regardless of the class it is in the topology.