Ionix IP/Smarts IP log contains 'AgentAddressList is empty.Cannot create instrumentation' error messages The following error messages are found in the Ionix IP/Smarts IP log file:
sys-setting.asl: SNMPAgent::SNMPAgent-10.x.x.x AgentAddressList is empty.Cannot create instrumentation. cpu-setting.asl: SNMPAgent::SNMPAgent-10.x.x.x AgentAddressList is empty.Cannot create instrumentation. env-setting.asl: SNMPAgent::SNMPAgent-10.x.x.x AgentAddressList is empty.Cannot create instrumentation. adapter-setting.asl: SNMPAgent::SNMPAgent-10.x.x.x AgentAddressList is empty.Cannot create instrumentation.
sys-setting.asl: SNMPAgent::SNMPAgent-GNSE-NY01-RT01 AgentAddressList is empty.Cannot create instrumentation. cpu-setting.asl: SNMPAgent::SNMPAgent-GNSE-NY01-RT01 AgentAddressList is empty.Cannot create instrumentation. env-setting.asl: SNMPAgent::SNMPAgent-GNSE-NY01-RT01 AgentAddressList is empty.Cannot create instrumentation. adapter-setting.asl: SNMPAgent::SNMPAgent-GNSE-NY01-RT01 AgentAddressList is empty.Cannot create instrumentation.
Environment
VMware Smart Assurance - SMARTS
Cause
The message observed is not an error, but just an information message. The IP addresses in the error message are those which were detected as duplicate IP addresses. For these duplicate SNMP_Agent IP addresses, Ionix IP/Smarts IP will usually create instrumentation for monitoring purposes. Because they are categorized as duplicate addresses, Ionix IP/Smarts IP will usually remove them from the AgentAddressList, and thereby end up having empty agentAddressList at some point.
Resolution
The above information messages can be ignored. The best option to remove these messages is to re-discover the device which was affected by the duplicate IP. Or, if the topology does not have a large number of devices, a complete re-discovery of the topology would resolve the issue.