Smarts IP: Network connection between devices is deleted during discovery when one device goes down and becomes unresponsive
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Article ID: 304209
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Network connection between devices is deleted during Smarts IP discovery when one device goes down and becomes unresponsive Cannot see network connection between devices when one device is down and unresponsive after Smarts IP discovery
When device goes down and unresponsive, the network connection is lost in the Smarts IP topology upon re-discovery
Environment
VMware Smart Assurance - SMARTS
Cause
Considering Device A and Device B as an example, this behavior occurs in Smarts IP as follows:
Scenario 1:
Device A goes down but connection is not lost between Device A and Device B. If only Device A goes down, the connections will not be removed.
Scenario 2:
Device A goes down and the connection is lost between Device A and Device B. In this scenario, the following occurs:
Device A goes down.
After doing a discoverAll, Smarts will discover both Devices A and B.
At this point, Device A is down and so not reachable, so the connection is not affected by Device A discovery.
However, Device B is also discovered with discoverAll, so the connection will be removed because Device B does not have information about its connection with Device A.
Resolution
No fix is available or required as Smarts IP is functioning as designed. When a device has lost its connection and a discovery (discoverAll) is run, the network connection between the devices are removed.