Smarts: {Unconnected} -> {Unconnected} error messages seen in the log files of various Smarts domains indicate that a connection was only up for a very short time
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Article ID: 304188
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
{Unconnected} -> {Unconnected} error messages seen in the log files of various Smarts domains indicate that a connection was only up for a very short time, with a timeout (tmo) value set to 15 seconds
The following error messages are seen in the log files of various Smarts domains:
[05-Jun-2008 16:57:54+136ms CEST] t@27 HTTP Accept CI-E-EWHILE-While executing function "read" CI-EFLOWID-For flow CI_FlowTCP_U [] IN_FLOW|NOREAD|NOWRITE|PHYSICAL . *:48000 KS 05-Jun-2008 16:57:54 CEST, KR 05-Jun-2008 16:57:54 CEST . Closed,{Unconnected} -> {Unconnected}, tmo 0 00:00:15 N/S 1/0 CI-EFLOWCLOSED-Flow has been closed; in file "/work/redcurrent/IC-6.5.3-rp/60/smarts/clsapi/ci_flow.c" at line 1801
Environment
VMware Smart Assurance - SMARTS
Cause
Log file messages like the one in the Symptom statement indicate that the connection was only up for a very short time. For a connection without keepalives like the one in the Symptom statement, the KR/KS values remain set to the connection establishment time, which will be less than a minute in the past from the time the message was logged. Also, the timeout (tmo) value being set to 15 seconds only happens during initial connection setup. This pattern can occur if someone started a connection, changed their mind, and entered CTRL/C on the client. Another common reason these messages are seen is application pinging, such as by Smarts ACM. Ping testers like Smarts ACM open a TCP connection to a server and immediately close it without sending any data. Smarts servers log that this happened when they fail to get the initial data they are expecting.
Resolution
These messages are not server error messages, are harmless and can be ignored.