Unable to authenticate or login to Global Console and Smarts servers
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Unable to authenticate or login to Global Console and Smarts servers

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Article ID: 304091

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

  • Unable to login in nor authenticate into Global Console and attach to a Domain Manager
  • Cannot login to Smarts servers

Environment

Smarts 10.1.X, 24.3.X

Cause

A misconfiguration in either serverConnect.conf or clientConnect.conf authorization files.

Resolution

Verify that the case spelling and syntax of the entries in the files match as documented. 

Example of correct matching entries:

serverConnect.conf         *:admin:changeme:All
clientConnect.conf         *:*:admin:changeme

Example of bad entries:

serverConnect.conf         *:admin:changeme:All
clientConnect.conf         *:*:admin:test                   <---  Password mismatch

serverConnect.conf         *:admin:changeme:All
clientConnect.conf         *:*:admin:changeme:All           <---  The ":All"  is not required in this line

serverConnect.conf         *:admin:changeme:ALL            <---  Only "A" should be capitalized
clientConnect.conf         *:*:admin:changeme

serverConnect.conf         *::admin:changeme:All             <---  Syntax doesn't require double colons
clientConnect.conf         *:*:admin:changeme