Unable to start server after a clean install of Smarts
search cancel

Unable to start server after a clean install of Smarts

book

Article ID: 304074

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Unable to start server after a clean install of Smarts
server tries to start and generates error and stack trace to server log file

Error message: Cannot connect to DM Broker: No process is connected to the specified location

Environment

VMware Smart Assurance - SMARTS

Cause

This error is generated by the server not being able to resolve the name "localhost".
 
Execute the following from command line:
  1. hostname
  2. cat /etc/hostname.*
  3. cat /etc/nodename 
Note the hostname of this device.

Resolution

  1. Edit file in <BASEDIR>/smarts/local/conf/runcmd_env.sh
  2. Change SM_BROKER= localhost:426 to <hostname>:426 or <ip address>:426


Additional Information

The following is the error message found in server log file in <BASEDIR>/smarts/local/logs/<domain server>.log:

Cannot connect to DM Broker at 'localhost:426/dmbroker': No process is connected to the specified location
CI-F-ETHROWTHIS-Exception being thrown:
 CI-EASSERTFAIL-Assertion failed: "si_uuid_creat(&uuid) != NULL"; in file
    "/work/redcurrent/IC-6.5-SP02/37/smarts/ga/parser/asl.y" at line 1497

Solaris 20900:
platform: V6.5 SP2(63875), 15-Jun-2006 23:41:48 - SmartPack 2, Build 37
libsm_clsapi.so (63875) 15-Jun-2006 23:48:41