Smarts: Interface status of NOTPRESENT in the Availability Manager (AM) Topology Browser causing Interface Down notification in Service Assurance Manager (SAM)
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Article ID: 304004
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Updated On:
Products
VMware
Issue/Introduction
Symptoms:
Interface status of NOTPRESENT in the Availability Manager (AM) Topology Browser causing Interface Down notification in Service Assurance Manager (SAM) When viewing the attributes of the interface in the Topology Browser, the AdminStatus, Status, and OperStatus all show NOTPRESENT.
Environment
VMware Smart Assurance - SMARTS
Cause
The interface index ID (ifIndex) that is currently in the Smarts topology is not the current ifIndex ID on the device's SNMP agent for the device in question.
To verify that this is the cause, complete the following actions:
In the Topology Browser, check the InterfaceNumber setting.
Match the InterfaceNumber setting in the Topology Browser against the ifIndex ID found during an SNMP walk of the device. To gather the walk, use the sm_snmpwalk utility located in IP/smarts/bin.
Check the SNMP walk or mimic file that is created to see if the ifIndex ID still exists on the agent at OID .1.3.6.1.2.1.2.2.1.1.X (where X is the ifIndex ID). SNMP mimic or walk files can be created with the following command:
If the InterfaceNumber setting in the Topology Browser does not match the ifIndex ID found during the SNMP walk, the Smarts topology is using the wrong number.
Resolution
Rediscover the device in question. When rediscovery is complete, the devices interfaces will be indexed properly, and the status will populate properly, as Smarts AM is now polling for the current ifIndex status data.