Smarts: After editing the serverConnect.conf or clientConnect.conf file, receive 'Login Failed' error when trying to connect to a Smarts domain
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Smarts: After editing the serverConnect.conf or clientConnect.conf file, receive 'Login Failed' error when trying to connect to a Smarts domain

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Article ID: 303977

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Cannot  remember the admin username, or password.
I need to return my admin/password to default values.

Receive "Login Failed" error when trying to connect to a Smarts domain

Receive the following error when logging in to a Smarts domain through the Global Console or Web Console:

Cannot attach to GlobalManager:
com.smarts.remote.SmInvalidLoginException: Login Failed

 

Receive the following errors when using a Smarts command line utility such as dmctl to access a domain from a Windows command prompt:

C:\InCharge7\IP\smarts\bin>dmctl.exe -s INCHARGE-AM-PM getc
[27-Aug-2008 9:38:40 AM+438ms Eastern Daylight Time]
t@5320 <Primary Thread>
AUTH-E-EWRITESTREAM-While checkFeature was writing to
    "C:\InCharge7\IP\smarts\bin\system\sm_authority.exe "
    encountered error: Bad file descriptor

[27-Aug-2008 9:38:40 AM+438ms Eastern Daylight Time] t@5320 <Primary Thread>
AUTH-E-STREAMFAILURE-Due to stream failure, unsuccessful login to ?1?: From
    ?2? ?3? pid=?4? IP=?5? ?6?

Cannot connect to DM Broker at '<broker_host>:426/dmbroker': Unable to authentiate
dmctl: Could not attach to 'INCHARGE-AM-PM': Cannot connect to DM Broker

 

Receive the following errors when using a Smarts command line utility such as dmctl to access a domain from a Unix or Linux system:

root@smarts# ./dmctl -s INCHARGE-AM-PM getc
dmctl: Could not attach to 'INCHARGE-AM-PM': Login to Domain Manager failed; permission denied

root@smarts#



Environment

VMware Smart Assurance - SMARTS

Cause

The serverConnect.conf file for the domain was incorrectly modified using a tool other than sm_edit. This can happen in the following cases:

  • A password was entered incorrectly. Since passwords are encrypted by default, you cannot verify this by looking at the serverConnect.conf or clientConnect.conf files.
  • The file was modified without using sm_edit, which can cause many problems. In one case, the serverConnect.conf file was saved with the improper case in its file name ("serverconnect.conf").

Resolution

Never edit any file in Smarts without using sm_edit. Smarts sm_edit ensures that the file you are editing is copied to the proper location in the local directory and has the proper case in the file name. Especially when modifying an authentication file (clientConnect.conf or serverConnect.conf), you absolutely MUST use sm_edit. Manually editing the files, especially if encryption is enabled, can cause them to become corrupted. It is also possible to have them saved with improper case (ie clientconnect.conf or serverconnect.conf).

To verify if the modified copy of the file contains an incorrect password and recover, do the following:

  1. Rename the copy of the problem file (clientConnect.conf or serverConnect.conf) in BASEDIR/smarts/local/conf. This will cause the sm_authorty process to use the default files in BASEDIR/smarts/conf and use the default user ID/password credentials of admin/changeme
  2. Attempt to login using the default admin/changeme user ID and password, and do the following: 
     
    • If you cannot login using the default admin/changeme user ID and password after renaming the local copies of clientConnect.conf or serverConnect.conf, restart the domain. The sm_authority process is probably hung and you must restart the domain for it to recover. When you can successfully login using the default admin/changeme user ID and password, go to the next step.
    • If you can now login using the default admin/changeme credentials, go to the next step.

       
  3. Use sm_edit to recreate any changes you made to the local copy of the file.