Error "cannot attach to global manager. com.smarts.store.sm not found exception" observed when attempting to connect to the global Console or thick client
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Error "cannot attach to global manager. com.smarts.store.sm not found exception" observed when attempting to connect to the global Console or thick client

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Article ID: 303964

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Updated On:

Products

VMware Smart Assurance VMware Telco Cloud Service Assurance

Issue/Introduction

Symptoms:

Unable to login through the Smarts Service Assurance Manager (SAM) console.

The following error is seen when attempting to connect to the Smarts Service Assurance Manager (SAM) Console:

cannot attach to global manager. com.smarts.store.sm not found exception

Cannot find the Smarts SAM instance ICS_UserProfile::ics-PROFILE-<user>-profile when the following command is used:

dmctl -s INCHARGE-SA getI ICS_UserProfile



Environment

SMARTS 10.1.x

TCSA 2.x

Cause

User profiles from the SAM repository have been lost.

Resolution

To restore user profiles, the original SAM domain must be restored from backup, and the user profile data extracted and then imported into production SAM. To do this, the following actions MUST be done from the server running SAM.

  1. Restore the original SAM repository (.RPS file) from a backup into a temp directory.
  2. Rename the restored file to the following:

    <SAM>-RESTORE.rps


  3. Copy <SAM>-RESTORE.rps into the following directory:

    <SAM>/smarts/local/repos/icf

     
  4. Run the following command from <SAM>/smarts/bin to startup the <SAM>-RESTORE domain:

    ./sm_server -n <SAM>-RESTORE -c ics --output --ignore-restore-errors

     
  5. Open a new command shell.

  6. In the new command shell, run
    ./brcontrol
     to make sure that the domain has started and is registered with the broker.

  7. Export the config data from the <SAM>-RESTORE by running following command:

    ./sm_config -s <SAM>-RESTORE export SAM-config-export.xml

    The above command will create a SAM-config-export.xml in the <SAM>/smarts/local/conf/ics directory.
     

  8. Run the following command against the production SAM domain to import the config:

    ./sm_config -s <production SAM> import --force SAM-config-export.xml