Smarts SAM Adapter Suite: Remedy Adapter: Unable to open tickets in Remedy; Communication failing; Error: 90: Message not in catalog; Message number = 90
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Smarts SAM Adapter Suite: Remedy Adapter: Unable to open tickets in Remedy; Communication failing; Error: 90: Message not in catalog; Message number = 90

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Article ID: 303946

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:


Unable to open Remedy tickets from Smarts Adapters

The following error is seen when attempting to use the Remedy adapter:

ERROR:
90: Message not in catalog; Message number = 90



Environment

VMware Smart Assurance - SMARTS

Cause

The error in the Symptom statement means the Remedy adapter is not communicating with a Remedy server. The Smarts SAM Remedy Adapter is configured using the file remedyConn.conf which contains 4 fields, delimited by a colon (:). 

If this file is not configured correctly communication will fail

Resolution

Two previous issues seen with configuration of the remedyConn.conf file:

1.) The remedyConn.conf file not edited correctly using sm_edit. The password field in this file is encrypted, therefore, the file needs to be edited using sm_edit so that the password will be encrypted correctly. If vi or another utility is used to edit this file, the password will remain in plaintext and communication will fail to the Remedy Server. 
Please update the file correctly using sm_edit to resolve this issue.

2.) The Remedy schema name contains a colon, this will cause the configuration file to be parsed incorrectly.

To resolve this issue, you need to put an escape character before the colon in the name of the Remedy schema. Edit the remedyConn.conf configuration file to include a backslash ( \ ) before the colon. 

Example:  For a Remedy schema name EMC:smarts, use EMC\:smarts.