Smarts SAM: Remedy ticket number is not being generated for Trap events in Smarts SAM
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Smarts SAM: Remedy ticket number is not being generated for Trap events in Smarts SAM

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Article ID: 303925

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Smarts Remedy ticket number is not being generated for Trap events in Smarts SAM
Smarts SAM Remedy Adapter remedy-opentkt.sh fails with the following error:

Executing the program:
/opt/InCharge7/SAM/smarts/local/actions/server/remedy-opentkt.sh
Opening Remedy Ticket for the first time
****************************************
Error: Cannot create Trouble Ticket
ERROR:
42075:
  The category, type, and Item combination is not valid. Select the category, type, and item in the field lists.

ICS-E-ACTION_SUCCESSFUL_WITH_OUTPUT-Execution of the program:
    '/opt/InCharge7/SAM/smarts/local/actions/server/remedy-opentkt.sh '
    completed successfully, with the output: '
  . '.
ICS-E-ACTION_CMD_STATUS-Action 'remedy-opentkt.sh' failed with status '5'.



Environment

VMware Smart Assurance - SMARTS

Cause

The definition of ClassName SNMPTrap in <BASEDIR>/SAM/smarts/local/conf/icoi/trap_mgr.conf is not configured as a Type in the Remedy server.

Resolution

To resolve this issue, you can do either of the following:

  • Change the ClassName of the trap definition in the trap_mgr.conf file from SNMPTrap to Host

    OR
     
  • Add SNMPTrap as a Type on the Remedy server.
     


Additional Information

This behavior can be observed by enabling tracing in the sm_arclient call in <BASEDIR>/SAM/smarts/actions/server remedy-opentkt.sh as in the following example:

${SM_ARCLIENT_EXE} --trace --file="${AR_FIELDS_INFO_FILE_FULL_PATH}" createEntry > ${TEMP_FILE} 2>&1