Smarts SAM 9.0: Telnet Client Tool does not work with the Global Console on Windows 7 and Windows Server 2008 (64-bit OS architectures)
search cancel

Smarts SAM 9.0: Telnet Client Tool does not work with the Global Console on Windows 7 and Windows Server 2008 (64-bit OS architectures)

book

Article ID: 303924

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Telnet Client Tool does not work with the Smarts SAM 9.0 Global Console on Windows 7 or Windows Server 2008 (64-bit OS architectures)

Environment

VMware Smart Assurance - SMARTS

Cause

The Smarts SAM 9.0 Global Console application is a 32 bit application. When the Global Console is started on a 64-bit operating system architecture like Windows 7 or Windows Server 2008, it will look into C:\Windows\SysWoW64 directory for the required libraries and system tools such as telnet.exe. However, a 32-bit version telnet.exe is not installed in this directory by the 64-bit OS by default. Because of this, the Global Console fails to launch the client telnet tool.

Resolution

To work around and address this issue, you can put a 32-bit version of telnet.exe in the C:\Windows\SysWoW64 directory.

CAUTION! Do NOT put a 64-bit version of telnet.exe in this directory. It must be the 32-bit version or it could crash the system.