Smarts IP: ASL error "MR-OBJECT_NOT_FOUND_EX-Cannot find object" found in IP server log file
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Smarts IP: ASL error "MR-OBJECT_NOT_FOUND_EX-Cannot find object" found in IP server log file

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Article ID: 303887

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:



 

Receive the following ASL error in Smarts IP server log file:

MR-OBJECT_NOT_FOUND_EX-Cannot find object

 

The following ASL errors are reported in the Smarts IP server log file:

[July 12, 2012 8:31:23 AM GMT+01:00 +477ms] t@1256499552 Discovery #10
ASL-W-ERROR_RULE_SOURCE-While executing rule set '/opt/InCharge8/IP/smarts/rules/discovery/ic-create-interface.asl'
ASL-ERROR_ACTION-While executing action at:
ASL-CALL_STACK_RULE- RuleName: EOF, Line: 113
ASL-ERROR_INVOKE-While attempting to invoke operation 'makeInterface' of object 'LoadBalancer::gold-slb-002-admin'
MR2-MR_WHILE_OPERATION_INVOKE-While invoking operation makeInterface in object 'LoadBalancer::gold-slb-002-admin'
MR-OBJECT_NOT_FOUND_EX-Cannot find object 'LoadBalancer::gold-bt1-slb-002-admin'
MR-CALL_ON_NULL_OBJECT-Tried to make a call on a NULL repository object; in file "/work/blackcurrent/DMT-9.0.0.X/1358/smarts/repos/servif/SM_RepositoryServer.c" at line 1089



Environment

VMware Smart Assurance - SMARTS

Cause

The "MR-OBJECT_NOT_FOUND_EX-Cannot find object" ASL errors will occur if a device does not exist in the topology and Smarts is trying to access it. In the following example scenario, all the devices below have the same sysName, sysOID and MAC, so as expected and as per Smarts design only one of the devices will be discovered in the topology.

gold-slb-001-admin
gold-slb-001-inbound
gold-slb-001-inbound-vpn
gold-slb-001-outbound

In this example, the IP server logfile extract for this issue could look like the following:

[July 16, 2012 1:56:31 PM GMT+01:00 +087ms] t@1245993312 Discovery #7

DSCV-W-DELETE_NODE-'LoadBalancer gold-slb-001-admin' is deleted because it is the same device as 'LoadBalancer gold-slb-001-outbound'

[July 16, 2012 1:56:31 PM GMT+01:00 +380ms] t@1256499552 Discovery #10

AD_MSG-*-AD_LOG-at 'ProbeClosure t@1256499552', while discovering 'gold-slb-001-admin', probe loop, null agent

"MR-OBJECT_NOT_FOUND_EX-Cannot find
object" These errors can be ignored.

As per design, Smarts uses multiple threads for discovery. As seen in the above logs, thread #7 has deleted gold-slb-001-admin and thread #10 is trying to

access gold-slb-001-admin, so there are ASL errors during discovery. But once the discovery is completed the duplicated devices will be deleted and there won't be any ASL errors.

Resolution

The Smarts IP "MR-OBJECT_NOT_FOUND_EX-Cannot find object" ASL errors observed in the server log file get logged by design based on configuration/topology elements. These errors can be ignored.