Error in Smarts discovery: ADTM-W-Bad value in SNMP response for OID
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Error in Smarts discovery: ADTM-W-Bad value in SNMP response for OID

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Article ID: 303874

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




error: ADTM-W-Bad value in SNMP response for OID '.1.3.6.1.2.1.1.1.0' :
'noSuchObject' for IP Address '62.96.179.33, port 161'
Device not properly discovered

Discovery error in server log file

Environment

VMware Smart Assurance - SMARTS

Cause

This indicates that the SNMP agent at 62.96.179.33 does not support the OID internet.mgmt.mib-II.system.sysDescr.  It probably doesn't support the entire system group in MIB-II, and it might not support anything in MIB-II at all.

Resolution

While unusual, this might be a valid SNMP implementation.  However, since our discovery relies on MIB-II (and the system group in particular), it will be incomplete for this device.  Customer needs to contact device vendor for updated SNMP agent.