Smarts AM: Card serial number showing invalid number
search cancel

Smarts AM: Card serial number showing invalid number

book

Article ID: 303835

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Card serial number showing invalid number

Environment

VMware Smart Assurance - SMARTS

Cause

Invalid serial number configuration for the device. The serial numbers for card devices depend on the MIB configured in the oid2type files in the Smarts discovery configuration directory (<BASEDIR>/IP/smarts/conf/discovery). The CONT=<MIB> setting in the oid2type files defines the MIB that Smarts will use to obtain the serial numbers for the card devices. These OIDs can contain invalid serial number data if they are not set properly by the network administrator.

For example, the CONT = Cisco-Router would tell Smarts to retrieve the Card Serial Number from the Cisco Router MIB OID (.1.3.6.1.4.1.9.3.6.11.1.4), while CONT=Cisco-Entity would tell Smarts to retrieve the Card Serial Number from the Cisco Entity MIB OID (.1.3.6.1.2.1.47.1.1.1.1.11).

Resolution

To verify and ensure that the serial numbers for the OIDs are set properly, do the following:

  1. Run a MIB walk as follows:

    <BASEDIR>/IP/smarts/bin/sm_snmpwalk -c <community string> <device name>

     
  2. Check for the MIB OID in the <device name>.mimic file in the smarts/bin directory. For example, check for OID .1.3.6.1.2.1.47.1.1.1.1.11 for the Cisco-Entity MIB OID. 
  3. Look for any invald serial number appended the MIB OID. In the following example, the bolded text shows the serial number format:

    .1.3.6.1.2.1.47.1.1.1.1.11.1: FF FF FF FF 46 46 46 46 FF FF FF

     
  4. If you find an invalid serial number, contact your system or network administrator to have them configure the correct card serial number.