Smarts NPM: Entry stating 'SM-EIO-Fatal I/O error' found in Smarts server log file
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Smarts NPM: Entry stating 'SM-EIO-Fatal I/O error' found in Smarts server log file

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Article ID: 303803

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:


In BGP log:

Entry stating SM-EIO-Fatal I/O error found in Smarts BGP server log file
Following error is found in Smarts Border Gateway Protocol (Smarts BGP) Server log:

[24-Oct-2008 05:30:50+481ms MEST] t@48 Discovery #3
ASL-E-ERROR_LOSTSERVER-Lost contact with remote server -- terminating parser
 ASL-ERROR_GET-While attempting to get property 'DisplayName' of object
    'MR_Object::SNMPAgent-ip-raif-ch-use-r-001'
 SM-EIO-Fatal I/O error

From SAM log:

March 29, 2016 8:40:54 PM GMT+00:00 +038ms 9141310 39848256 WARN SM_ProtocolEngine-175 7357 ICS_RSM SM_EIO SVIF-W-WRSTSRV_IO-AMER-ICR4 I/O Error in remote command 'invokeOperation(className, instanceName, opName, args)'; Reconnecting... CI-EWHILE-While executing function "write" CI-EFLOWKEEPALIVESEND-Flow closing due to inability to send keepalive at March 24, 2016 11:00:39 PM GMT+00:00 +587ms <SYS>-ECONNRESET-Connection reset by peer CI-EFLOWCLOSED-Flow has been closed; in file "/work/tancurrent/DMT-9.3.0.X/2/smarts/clsapi/ci_flow.c" at line 2750 SM-EIO-Fatal I/O error; in file "./SM_RemoteServer_.c" at line 3516

Environment

VMware Smart Assurance - SMARTS

Cause

The Smarts BGP server has lost contact with the remote Smarts AM server in the middle of the discovery operation. This is most likely a system or network problem on the system which is running the Smarts BGP server. The SM-EIO-Fatal I/O error is from <sys/errno.h>, and the platform code is simply passing the strerror() return string. This means that although Smarts is registering an exception, the "Fatal I/O error" does not represent a fatality to the Smarts BGP thread or process.

SM-EIO-Fatal I/O error can occur any time that a domain cannot successfully connect to a subscribed domain.  Typically, it indicates some sort of network communication failure.

Resolution

Investigate whether there is system or network problem on the system which is running the Smarts BGP server, and resolve if found. The Smarts AM log file may contain clues to the cause of the system/network problem.