Errors stating 'SM-EIO-Fatal I/O error' found in BGP Domain Manager log files
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Errors stating 'SM-EIO-Fatal I/O error' found in BGP Domain Manager log files

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Article ID: 303803

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Updated On:

Products

VMware Smart Assurance Network Observability

Issue/Introduction

Following log Entry stating SM-EIO-Fatal I/O error found in BGP Domain Manager server log file

[<Date & Time>] t@<epoch> Discovery #3
ASL-E-ERROR_LOSTSERVER-Lost contact with remote server -- terminating parser
 ASL-ERROR_GET-While attempting to get property 'DisplayName' of object
    'MR_Object::SNMPAgent-<device>'
SM-EIO-Fatal I/O error

Environment

All Supported Smarts releases

Cause

The Smarts BGP server has lost contact with the remote Smarts AM server in the middle of the discovery operation. This is most likely a system or network problem on the system which is running the Smarts BGP server. 
The SM-EIO-Fatal I/O error is from <sys/errno.h>, and the platform code is simply passing the strerror() return string.
This means that although Smarts is registering an exception, the "Fatal I/O error" does not represent a fatality to the Smarts BGP thread or process.

SM-EIO-Fatal I/O error can occur any time that a domain cannot successfully connect to a subscribed domain.  
Typically, it indicates some sort of network communication failure.

Resolution

Investigate whether there is system or network problem on the system which is running the Smarts BGP server, and resolve if found.
The Smarts AM log file may contain clues to the cause of the system/network problem.

Get in touch with the Broadcom Support for more assistance.