Smarts VoIP AM: Nortel devices on Signaling Servers are being added to pending list after discovery by Smarts VoIP AM
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Smarts VoIP AM: Nortel devices on Signaling Servers are being added to pending list after discovery by Smarts VoIP AM

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Article ID: 303787

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Nortel devices on Signaling Servers are being added to pending list after discovery by Smarts VoIP AM
Nortel devices on Signaling Servers discovered by Smarts VoIP Availability Manager are being added to pending list

The following message is present in the EXCEPT file in Smarts VoIP Availability Manager environment:

am> ===== SECT_TPSSHOW =====
tpsShow
oam> can't read "hostname": no such variable
    while executing "send_user "Timeout Occurred: isMasterSS Check Failed on $hostname.\n""
    invoked from within "expect -nobrace -re {( .*)(Is.*master.*)(: 1)(
)} {       send_user "DEBUG1: Its a MASTER. Returning TRUE.\n" return "TRUE"
    } -re {(
..."    invoked from within
"expect {-re "(\r"\n".*)(Is.*master.*)(: 1)(\r"\n)" {send_user "DEBUG1: Its a MASTER. Returning TRUE.\n"
      return "TRUE" } -re ..."
    (procedure "isMasterSS" line 5)
    invoked from within "isMasterSS 1"
    invoked from within "expect -nobrace -re Goodbye... { send_user "Wrong password on $hostname.\n"
        exit
    } -re {(.*)(Timed out)(
.*)} { sen..."  invoked from within "expect {
    -re "Goodbye..." {   send_user "Wrong password on $hostname.\n"
        exit
    }   -re "(\r"\n".*)(Timed out)(\r"\n".*)" { ..."   (file "/opt/InCharge7/VoIP/smarts/local/script/voip/nortel/nortel_commands.exp" line 84)



Environment

VMware Smart Assurance - SMARTS

Cause

Signaling Servers are placed in the Smarts VoiP AM Pending list because TPS is not being run, and this occurs because of a problem in the Smarts VoIP AM software. Smarts VoIP code incorrectly assumes that the "tpsShow" command is always available with Nortel Devices on Signaling Servers. If this command is not available on the server, the above symptoms are observed and the devices will be added to the pending list.

Resolution

EMC Smarts Engineering is investigating the requirements to resolve this issue in an upcoming Smarts VoIP release. Contact EMC Support for Smarts for more information concerning the release of this fix.