Smarts SAM: Can access WebConsole but not Smarts domains; Which firewall ports must be open to allow a host access the WebConsole and all Smarts domains?
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Article ID: 303733
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Updated On:
Products
VMware Smart Assurance
Issue/Introduction
Symptoms:
Which firewall ports must be open to allow a host access the Smarts Service Assurance Manager (Smarts SAM) WebConsole and all Smarts domains? For a host trying to access the Smarts SAM webconsole on one side of a firewall and all of Smarts products/domains on the other side, which ports are required to be opened?
Can access the Smarts SAM WebConsole, but not Smarts domains Able to access the Smarts SAM WebConsole, but cannot view the Smarts domains running on the broker.
Able to access the Smarts SAM WebConsole and view the Smarts domains running on the broker, but cannot attach to any of the domains.
Cannot access the Smarts SAM WebConsole through a firewall.
Environment
VMware Smart Assurance - SMARTS
Cause
A host trying to access the Smarts SAM WebConsole through a firewall where the host and Smarts are on opposites sides of a firewall will not work correctly unless the WebConsole Port (default 8080), broker port (default 426), and all the respective ports that each Smarts domain is started on are not open.
Resolution
Port reference can be found in CONSOLE/smarts/tomcat/conf/server.xml.
Ensure that the following ports are open in the firewall:
WebConsole port (default 8080)
Broker port (default 426)
Open each Smarts domain port in the firewall you wish to attach to from the WebConsole (IP/SAM/OI and so on)