Smarts IP 8.1.3: Receive "Subscription Change" messages in APM server log; Can we disable/prevent these messages?
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Smarts IP 8.1.3: Receive "Subscription Change" messages in APM server log; Can we disable/prevent these messages?

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Article ID: 303726

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:


Can we disable/prevent these "Subscription Change" messages that are appearing in the Smarts IP Management Suite (Smarts IP) 8.1.3 APM server log?

Receive "Subscription Change" messages in Smarts IP 8.1.3 APM server log

Messages similar to the following are found in the Smarts IP 8.1.3 APM server log:

[July 19, 2012 6:55:38 AM GMT+01:00 +894ms] t@1361635648 SM_ProtocolEngine-22 unknown IC Console - V8.0.0.0
RSVI_MSG-*-SUB_CHG-Subscription change: propertySubscribe client: SM_SocketObserver-22 unknown IC Console - V8.0.0.0 property: PowerSupply::PWR-fx-1111586-cx1-za-sdt/1::DisplayName

[July 19, 2012 6:55:38 AM GMT+01:00 +913ms] t@1361635648 SM_ProtocolEngine-22 unknown IC Console - V8.0.0.0
RSVI_MSG-*-SUB_CHG-Subscription change: propertySubscribe client: SM_SocketObserver-22 unknown IC Console - V8.0.0.0 property: Processor::PSR-fx-1111586-cx1-za-sdt/1::DisplayName



Environment

VMware Smart Assurance - SMARTS

Cause

The environment variable SM_SUBSCRIPTION_TRACE is introduced in IP 8.1.3 to controls tracing of the subscription changes in the server log. The above messages are being generated in the APM logs because of the property subscription from the SAM server. These messages are used for debugging purposes.

Resolution

Tracing is enabled by default and disabling this tracing is not recommended. If you require this tracing to be disabled in your environment, contact EMC Customer Support Services (CSS) for Smarts IP and reference this solution ID.