Smarts AM: Multiple routers being marked "Down" in response to only one Router Unresponsive event
search cancel

Smarts AM: Multiple routers being marked "Down" in response to only one Router Unresponsive event

book

Article ID: 303718

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Multiple routers are being marked Down by Smarts IP Availability Manager (Smarts AM) in response to one Router Unresponsive event
Routers being marked Down as the Root Cause when they should be Impacts of an Router Unresponse event

Environment

VMware Smart Assurance - SMARTS

Cause

This problem will occur when partitions are disabled. An empty partitions.conf file in <BASEDIR>/IP/smarts/local/conf will prevent the domain from creating partitions.

The following is the logic Smarts uses to determine that a Router is DOWN:

(IsUnresponsive && (HasNoPartition || !IsEveryNeighborUnresponsive))

So, if Router A is Unresponsive and Router B is responsive, Router A will be marked Down if it did not belong to a partition. 

Resolution

To resolve this issue, remove any partitions.conf file in the <BASEDIR>/IP/smarts/local/conf directory so that partitions can be created correctly.