Smarts: After Smarts upgrade, receive WARNING: register package errors in the command line and the domain logs
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Smarts: After Smarts upgrade, receive WARNING: register package errors in the command line and the domain logs

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Article ID: 303715

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




After Smarts IP upgrade, receive WARNING: register package errors in the command line and the domain logs
During the upgrade process, files in the local folder with a sitemod enabled folder was not updated with the new version of files that came with the installer

During the upgrade process files in the <basedir>/smarts/local/l10n/ directory were not updated with the new version of files that came with the installer

Smarts data files (*.dat) files located under the <basedir>/smarts/local/l10n folder are not synchronized with the patch/upgrade.

Receive the following errors in the command line console after Smarts upgrade:

WARNING: register package 'bignumerr' version 342a6bac failed (0x276f4e05)
WARNING: register package 'cryptoerr' version d25a9d40 failed (0x276f4e05)
WARNING: register package 'mainerr' version 79811d2b failed (0x276f4e05)
WARNING: register package 'moderr' version 9729aecd failed (0x276f4e05)
WARNING: register package 'ci_errtab' version 02c204f2 failed (0x276f4e05)
WARNING: register package 'sm_errors' version ba949cd5 failed (0x276f4e05)
WARNING: register package 'nx_error' version 352b4838 failed (0x276f4e05)
WARNING: register package 'sm_brerrors' version dad197da failed (0x276f4e05)
WARNING: register package 'ci_msg' version 599ea6f4 failed (0x276f4e05)
WARNING: register package 'miscerr' version 76bb5414 failed (0x276f4e05)
WARNING: register package 'sms_msg' version f4256f40 failed (0x276f4e05)



Environment

VMware Smart Assurance - SMARTS

Cause

This warning is caused by the .dat files in <basedir>smarts/ local/l10n folder are not up to date after upgrade or patch.
This message can also occur if your library path isn't correctly set.

Resolution

If you encounter this issue check to make sure that the setting in the runcmd_env.sh files and your paths are correct.  If so, do the following:

  1. Make a backup copy of the <basedir>/smarts/local/l10n folder.

  2. Go to the <basedir>/smarts/local/l10n folder through command line for Linux or Windows Explorer for Windows.

  3. Remove/delete all files that match the name of the errors present in the log.
     
    • Example: WARNING: register package 'ci_errtab' version 02c204f2 failed (0x276f4e05) = errtab_eb1.dat and errtab_eb2.dat 

       
  4.  Restart the Smarts IP/SAM domain.